Creating Web Pages with Dreamweaver

Your written responses to the exercises and further work will form part of your next portfolio – you should keep a written record of them (either on paper or as a text file). 

Exercise 1: Modifying Text and Creating Text Links 
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Exercise 1a: Creating a Title 

Start by typing anything into the document window. For example: "My First Dreamweaver Page"
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Now that you have some text, you can modify. There are at least three ways you can modify your text: 

1. Editing the actual HTML code 

2. Using the Text menu options and 

3. Using the Property window. 

Editing the HTML code is pretty messy and you need to know what you are doing. So let's not do that.

Text menu options are perfectly legitimate ways to modify your text and you should explore the Text menu when you have time. 

But the easiest way is to use the 

Property Window.
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Format is used to change the header size of the selected Text. Select the text that you just typed and click on the dropdown box. You can select Paragraph, Header (sizes 1-6) and Preformatted.

Header 1 is the largest header size available. Select Header 1. Your text should now appear very large and bold.

Text next box allows you to change from the default font to commonly recognised fonts. Select Arial. (make sure that your text is still highlighted)

The next option in the property window is size. This will change the size of the font. Typically you do not size the size if you are using header to control the font size. Font sizes vary from (1 to 7, +1 to +7 and -1- to -7) 1 to 7 are absolute font sizes and the sizes with + and - are relative font sizes.

For this exercise, leaves the font size option blank or set to none.

The next box, which looks like a grey box, is the font colour selector. When you click on this box a colour picker will show up. 
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You can choose any colour by clicking on it. Or you can click on the pallet in the bottom left and mix the colour of your choice. You might noticed that if you move the cursor off the colour picker it turns into an eye dropper, you can use the eye dropper to select the colour off of any object in your page. This is useful when you want to match your text colour with the colour of an image you are using in your page.

Click on any colour. (make sure that your text is highlighted)

The next icons should be familiar to you if you've used programs like MS Word. B is bold, I is for Italic and the next three icons set the alignment of the font on the page. Click on the middle of these three icons. (make sure that your text is highlighted) This will centre your text. The next set of icons in this section allow you to created bulleted lists, numbered lists and indent or unindent your text. Again, this is similar to Word.

You should now have something that looks similar to this:
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Summary Exercise 1a: Creating a Title
1. Type: "My First Dreamweaver Page" in the document window. 

2. Highlight the title using the mouse. 

3. Change the format to Header 1 

4. Change the default font to Arial 

5. Change the text colour 

6. Centre the title 
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Exercise 1b: Line Spacing

Press enter and add more text to your page. You will notice that if you start a new line you are still in header 1 mode. To change this go to the Property Window and change the format to none or paragraph.
You may have noticed that pressing return will create a new paragraph. If you want to have a regular line break you can do this by pressing shift-enter. For Example:

Paragraph Breaks

Type "Line 1"
Press enter 
Type "Line 2"
Your Results:


Line 1

Line 2

Line Breaks

Type "Line 3"
Press shift-enter 
Type "Line 4"
Your Results:


Line 3
Line 4
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Line breaks can also be inserted by clicking on the "BR" icon located in Objects Window.

Notes on Line Wrapping
When you type a line that exceeds the width of your browser window it will automatically wrap (move down) to the next line. In most cases it is best to let the browser wrap your text rather than manually inserting line breaks.
Delete the text created above (i.e. Lines 1 -4)

Summary Exercise 1b: Line Spacing
1. Add more text to document (note that text retains format of Title) 

2. Change the format to none or paragraph 

3. Type "Line 1"
Press enter 
Type "Line 2" (note the line spacing) 

4. Type "Line 1"
Press shift-enter 
Type "Line 2" (note the line spacing) 

5. Delete the text created in steps 3 and 4 
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Exercise 1c: Creating Text Links

Type: "My School: Brunel University" Press Enter to go to the next line.
Type: "My Email: "

First we will link the words "Brunel University" to the Brunel home page.

1. Highlight the words " Brunel University " 

2. Type: "http://www.brunel.ac.uk" in the Property Window's Link Box 

You have now created your first text link to Brunel University.
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To create mail links you need to use the Objects Window
Place your cursor after the colon on the line that says "My Email: " and click on the envelope icon in the Objects Window. 

 

In the Text box type your name. "YOUR NAME"

In the E-mail box type your email address. "YOURLOGIN@brunel.ac.uk"

Click OK.

 

This will create an email link on your page. 

View your page on the Web by pressing F12 or go to File>Preview on Browser
Linking to Pages in Your Own Site

When you are linking to other pages you created that are in own site, you do not need to put the full URL (i.e. "http://web.brunel.ac.uk/~login/mypage.html") in the Link box in the property window. Simply put the name of the HTML page you wish to link to in the link box. (i.e. "mypage.html")

You can also browse to the page you wish to link to by clicking on the folder icon after the link box if the file is located on your computer.
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The Target box is used when you have a page with frames.

Summary Exercise 1c: Creating Text Links
1. Type: "My School: Brunel University" 

2. Type: "My Email: YOUR NAME" 

3. Create a text link from " Brunel University " to "http://www.brunel.ac.uk" 

4. Create an email link from YOUR NAME to your email address 
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Exercise 1d: Saving Your Page

Click on File>Save As...
Browse to the H drive and save your file as "sample.html" in a new sub-folder (e.g. “dw_wk1”) of the ‘webhome’ directory.

Because of problems with Dreamweaver/ Windows, do not create this sub-folder from within Dreamweaver’s Save As dialogue – create it separately using Explorer or My Computer instead!

Summary Exercise 1d: Saving Your Page
1. Save Page as "sample.html" on H drive or on your floppy disk. 

Exercise 2: Adding Images and Linking Images
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Exercise 2a: Adding an Image

To add images to your WebPages you will need to use the Objects Window.
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To add an image, you need to have an image available on your computer or on disk. Copy the image to the dw_wk1 sub-folder.

Click on the first icon in the objects window. (The icon with the tree)

This will bring up a browse window.

Browse to the location of the saved image and select the image.

The image that you have selected should appear in your sample.html page. 

Notice that when you click on the image, the Property Window display different information now.

You can distort the image by changing the W(idth) and H(eight) sizes.

You can change images by changing the Src name, or clicking on the folder, browsing and selecting a new image.

The Align option refers to how the text flows around the image. If you want text to be displayed on the left or right side of the image, select left or right. By default text appears to the bottom right of the image.

Alt is to display optional text while the images is loading or if you place the cursor of the image for a few seconds the alt text will be displayed. 

[image: image1]You can centre the image or move it left or right by clicking on one of the three alignment icons. 

Exercise 2b: Linking an Image

You can link images to other pages or sites just like you can have text links. Linking images is exactly like creating text links.

Click on the image and type "http://www.yahoo.com" in the link box in the property window.
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This will link the image to Yahoo. View your page by pressing F12

Save sample.html by going to File>Save

Exercise 3: Page Formatting

Modifying Page Properties

Select Page Properties Modify>Page Properties... from the menu options in the document window.

Change the Page Title. In this case change the title to "My Sample Dreamweaver Page"

Background Colour
This is the background colour of you WebPages. This option works the same way as changing the font colour. Click on the box and select a colour to change your background colour. Click on Apply to see the changes.

Text, Links, Visited Links, Active Link Colour
Changing these colours works the same as changing font colour.

· Text - This is the default colour of all the text on your page 

· Links - This is the colour of all the links on your page. By default the are blue 

· Visited Links - This is the colour of the link if you have been to the linked page already. 

· Active Links - This is the colour of the link when you click on it. 

Try changing the text colour and applying the change.
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Background Image
This option will tile an image over the whole page. If you have a background image selected it will override any background colour selections you have made.

Modify the Page Properties and set the background image by browsing to your file and selecting a background image. Click Ok.
Background Images are best if they are subdued images. Busy images will distract from the content of the page or make it really difficult to read.

Save "sample.html" by going to File>Save

Exercise 4: Viewing Your Web Pages and Images 

At Brunel, if your files are in your webhome directory they don’t need uploading – you just need to set the file permissions.

However you should also set up the Site Manager to keep track of your site and draw up the site map.
The Site Manager can be reached using Window>Site Files or using the Site Icon in the lower right hand of the document window, or from the Launcher:
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From the Site Window click on Site>Define Site
Click on "New"

Configuring Site Information
1. Change the Site Name to whatever you want your site to be called. 

2. Change the Local Root Folder to H drive. Click on the folder icon to browse to the sample files 

3. Set the HTTP Address to "http://www.brunel.ac.uk/~YOURLOGIN" 

4. Click on Web Server Info under the Category section on the left. 

5. Change Server Access to None 

6. Click OK 

Click Done on the Define Site dialogue box

The left side of the Site Manager shows the Remote Site or files on the webserver. 

The right side shows the Local Folder. These are the files that are located on the folder that you specified when you defined the Local Root Folder.

Viewing Your Web Site

Before viewing your Web Site, first you have to set permissions by going to 

Start(Network programs(Utilities(Set www homepage permissions

Your web address is:

http://www.brunel.ac.uk/~YOURLOGIN

Your newly uploaded file will be located at:

http://www.brunel.ac.uk/~YOURLOGIN/dw_wk1/sample.html

You should be able to view sample.html (and its images) successfully if you have completed all the previous steps. You should now be able to create simple web pages for your site.

Exercise 5: Uploading Your Web Pages

In this exercise we’ll pretend to have a remote server, and practice moving data back and forth.

First exit Dreamweaver and move the contents of the dw_wk1 folder into local at the top of your H: tree. Can you still see your files in Netscape? (Remember, we want to see those URLs starting with an http:// ... ! )

Now re-open Dreamweaver.

For this section you will need to use the Site Manager. You could also upload your pages and images using a traditional FTP program such as WSFTP or Fetch.

The Site Manager can be reached using Window>Site Files or using the Site Icon in the lower right hand of the document window, or from the Launcher.
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From the Site Window click on Site>Define Site
Click on "New" (or “Edit” if the site already exists)

Configuring Site Information
1. Change the Site Name to whatever you want your site to be called. 

2. Change the Local Root Folder to H: drive. Click on the folder icon to browse to the moved material in H:\local
3. Set the HTTP Address to "http://www.brunel.ac.uk/~YOURLOGIN" 

4. Click on Web Server Info under the Category section on the left. 

Configuring Web Server Information

5. Change Server Access to Local/Network 

6. Set the Remote Folder: "H:\webhome\remote" 

7. Click OK 

Click Done on the Define Site dialogue box

The left side of the Site Manager shows the Remote Site or files on the web server. 

The right side shows the Local Folder. These are the files that are located on the folder that you specified when you defined the Local Root Folder.
The Difference between GET and PUT

GET - Get files off the web server
PUT - Put files on the web server

Select sample.html from the right side or local side. Click on the put icon.
Dreamweaver will ask you if you want to include dependent files. Click Yes. 

This means that if there are any images in sample.html it will upload those files as well. In this case it should upload 'your image' and 'background image' as well as sample.html.

After you click on put, sample.html, image.gif, and background-image.jpg will be on the remote site.

You now have your files stored “locally” in H:\local and “remotely” in H:\webhome\remote . Make a series of small changes to the “local” files and practice using Site Manager both to upload them and also to recover old ones from the remote host. What is the URL of the site now? (you may need to reset permissions again)

Close Dreamweaver again. Delete the contents of H:\webhome\remote. Now, using Explorer or My Computer, move just the images in your site to a new sub-folder of your “local” directory, say from H:\local to H:\local\images.

Re-open Dreamweaver. What happened? (fix it!)

Now what happens on the “remote” host when you upload the fixed site?

Now try moving the image files back up into your Local Root, this time from within Site Manager – what happens this time?

Summary

You should now be able to create a simple website using Dreamweaver 3, using the Document and Property windows to manipulate single pages, and Site Manager to maintain links. 

Notice that maintaining both the “local” and “remote” data on H: wastes your quota – from now on you shouldn’t need the “remote” host and can set up as in Ex. 4. Alternatively, if you are also working on your site at home, you could use a Zip or floppy disk as a local folder.

Further Work

Last week you were asked to try looking at the HTML source to a couple of web pages from an object-based object approach. You should have some notes on how HTML implements an object-based description of a document. Compare this approach to how Dreamweaver's page editor behaves - look at Dreamweaver’s property windows for a standard heading, a link and an image. You may want to use the F10 key in Dreamweaver to display the HTML source of the current page. Incorporate your conclusions with any notes you made in the "Further Work" section of the initial exercises.

Using a DW online tutorial or book, learn the following topics before the next lab session:

· Links and anchors (external and internal links)

· Images and image maps (how to place images in DW, create image maps and link images)

· Basics of tables and frames in DW

You could also link in a couple of extra pages and try generating a site map.
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